Commit 2449b73d authored by opencadc-admin's avatar opencadc-admin Committed by GitHub
Browse files

Merge pull request #2 from andamian/s1965

S1965
parents 0a5a738e dbdecc3b
language: java
jdk:
- openjdk7
- oraclejdk8
script: for mod in cadc-access-control cadc-access-control-admin cadc-access-control-identity cadc-access-control-server cadc-tomcat; do cd $mod; gradle assemble check install; cd ..; done
...@@ -19,26 +19,3 @@ Where command is: ...@@ -19,26 +19,3 @@ Where command is:
-d|--debug : Debug mode print all the logging messages -d|--debug : Debug mode print all the logging messages
-h|--help : Print this message and exit -h|--help : Print this message and exit
``` ```
## Depdencies
### opencadc dependencies
- opencadc/ac/cadcUtil
- opencadc/ac/cadcLog
- opencadc/ac/cadcAccessControl
- opencadc/ac/cadcAccessControl-Server
### external build dependencies
- log4j.jar (log4j-1.2.17.jar)
- commons-logging.jar
- unboundid.jar
- servlet-api
- mail
### external test dependencies
- asm.jar (hibernate-3.2.3)
- cglib.jar (hibernate-3.2.3)
- easymock.jar (easymock-3.0.jar)
- junit.jar (junit-4.6.jar)
- objenesis.jar (objenesis-1.2.jar)
plugins {
id 'java'
id 'maven'
id 'maven-publish'
id 'com.jfrog.bintray' version '1.7.1'
}
repositories {
jcenter()
mavenLocal()
// Only here until cadcUtil is in jcenter.
maven {
url 'http://dl.bintray.com/opencadc/software'
}
}
sourceCompatibility = 1.7
group = 'org.opencadc'
version = '1.0'
dependencies {
compile 'log4j:log4j:1.2.+'
compile 'org.jdom:jdom2:2.+'
compile 'javax.servlet:javax.servlet-api:3.+'
compile 'xerces:xercesImpl:2.+'
compile 'com.unboundid:unboundid-ldapsdk:2.3.+'
compile 'commons-fileupload:commons-fileupload:1.3.+'
compile 'com.sun.mail:javax.mail:1.+'
compile 'org.opencadc:cadc-util:1.+'
compile 'org.opencadc:cadc-log:1.+'
compile 'org.opencadc:cadc-registry:1.+'
compile 'org.opencadc:cadc-access-control:1.+'
compile 'org.opencadc:cadc-access-control-server:1.+'
testCompile 'junit:junit:4.+'
testCompile 'org.easymock:easymock:3.+'
testCompile 'xerces:xercesImpl:2.+'
testCompile 'org.skyscreamer:jsonassert:1.+'
}
Supports Markdown
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment